Spring Boot 2.4发布了,但Spring Cloud用户不推荐着急升级

【福利】设计模式学习笔记,点击领取

前段时间Spring Boot发布了本年度最后一个重要更新版本:Spring Boot 2.4.0。

最近在社群里也开始有讨论关于Spring Boot 2.4的一些使用问题。我发现有很多Spring Cloud用户也急切着想要体验最新版本的Spring Boot,然后碰到了一些问题,其中被提出来最多的就是配置无法加载的问题。

我没有去深究这个问题如何去解决,因为之前,在发布说明中有提及过,在Spring Boot 2.4版本中对配置文件的处理做了较大的改动,如果你只是简单的使用application.properties或application.yaml,那么还能无缝衔接。但如果用了更为复杂的配置方式,很可能会失败。

所以,当你采用Spring Cloud Config来管理配置和加载的时候,就很容易出现这样的问题。同时,从Spring Boot和Spring Cloud的版本支持关系来看,Spring Boot 2.4.x版本本身还没有对应的Spring Cloud版本。

上图截取自:http://www.springcloud.com.cn/

因此,对于Spring Cloud的用户的话,当前时间节点之下,并不太推荐马上去应用Spring Boot 2.4.x。